Ślad: • kontrolki • plan • analiza_kodu_lab

Statyczna analiza kodu

Writing /home/grochu/public_html/wiki/data/cache/e/e87d51de7a1bb63386d26ba4c27f1c90.i failed
Unable to save cache file. Hint: disk full; file permissions; safe_mode setting.
Writing /home/grochu/public_html/wiki/data/cache/e/e87d51de7a1bb63386d26ba4c27f1c90.metadata failed
Writing /home/grochu/public_html/wiki/data/cache/2/214a7a88ab5ad2c42f60c1efc3cfe40f.i failed
Writing /home/grochu/public_html/wiki/data/meta/zajecia/znd_2017_1/sidebar.meta failed
Unable to save metadata file. Hint: disk full; file permissions; safe_mode setting.
Writing /home/grochu/public_html/wiki/data/cache/e/e87d51de7a1bb63386d26ba4c27f1c90.i failed
Unable to save cache file. Hint: disk full; file permissions; safe_mode setting.

Statyczna analiza kodu

Ćwiczenia

  1. Połącz się z projektem zespołowym npr w kolekcji sandbox
  2. Otwórz w VS projekt SnakeGame
  3. Przeprowadź analizę kodu Analyze → Run Code Analisis
  4. Spróbuj naprawić wykryte błędy, zapoznaj się z opisem regół, które wykryły podejrzane fragmenty kodu
  5. Dodaj wszystkie zestawy regół i uruchom analizę ponownie
  6. Skonfiguruj analizę kodu tak aby była uruchamiana przy każdej kompilacji
  7. Utwórz własny zestaw regół (RuleSet) i zapisz go pod nazwą „NPRRuleSet”. Skonfiguruj wybrane regóły z tego zbioru tak aby generowały błąd kompilacji.
  8. Utwórz zgłoszenie związane z jednym z wykrytych błędów
  9. Dodaj do kodu atrybut powodujący pomijanie jednego z ostrzerzeń przy analizie (w pliku )
  10. Aktywuj Resharpera i przeprowadź analizę całego rozwiązania i postaraj się usunąć wszystkie ostrzerzenia
    • Okno Errors in solution
    • Inspekcja kodu, okno Inspections (Inspect → Code issues in Solution)
  11. Zapoznaj się z ustawieniami dotyczącymi inspekcji kodu, zwłaszcza z poziomami ostrzeżeń dla poszczególnych regół (Options → Code Inspection → Inspection Severity )
  12. Przeprowadź automatyczne czyszczenie kodu Tools → Cleanup Code
    • Sprawdz ustawienia dotyczące automatycznego czyszczenia kodu (Options → Code Editing → Code Cleanup)
    • Dodaj własny profil czyszczenia i skonfiguruj go wg. swoich zapartywań