OpenGL Embedded Systems

Instrukcja instalacji niezbednego oprogramowania

Czym jest OpenGL ES?

To podzbidr biblioteki OpenGL zaprojektowany dla urzadzed mobilnych (telefony komdrkowe,
konsole do gier). W systemach takich jak Symbian, Android i iOS stanowi oficjalne API dla grafiki
tréjwymiarowe;j.

Co bedzie potrzebne?

Chcac rozpocza¢ swojg przygode z aplikacjami tréjwymiarowymi na platformie Android nalezy
zaopatrzy¢ sie w podstawowe narzedzia, ktére to umozliwig. Nalezg do nich:

— Android SDK (najlepiej najnowsze)

— Java Development Kit (przynajmniej w wersji 5)

— Java Runtime Environment

— Srodowisko programistyczne (polecam Eclipse) wraz z wtyczka ADT (Android Development
Tools)

Co jest wymagane od programisty?

Jako, iz zajmujemy sie aplikacjami na urzadzenia zaopatrzone w Androida, ktéry zostat napisany w
jezyku Java wymagana jest przynajmniej podstawowa wiedza dotyczgca programowania aplikacji w
tym jezyku. Java jest jezykiem obiektowym, wiec nie trzeba wspominac o znajomosci podstaw OOP.

Czego nie bedzie na prezentacji?

Referat nie bedzie traktowaé¢ o podstawach programowania obiektowego. Licze, ze uczestnikom
kursu nie sg obce takie pojecia jak klasa, instancja, dziedziczenie, polimorfizm. Licze tez, ze kazdy
potrafi napisaé prostg aplikacje (chociaz konsolowg) w jezyku Java. Jezeli tak nie jest - odsytam do
dokumentacji Javy na stronie Oracle'a.

Skqd oprogramowanie?

Na kursie postuze sie srodowiskiem Eclipse (w wersji Classic 3.7.1, wazgce nieco ponad 174 MB).
Mozna je bezptatnie pobra¢ ze strony producenta - http://eclipse.org/. Mimo 64-bitowego systemu
skorzystamy z wersji dla systemu 32-bitowego. Jest czesSciej aktualizowane, mozemy znalezé dla
niego wiecej wtyczek i dodatkéw, anizeli dla 64-bitowego brata. Mimo postepu dostawcy
oprogramowania wcigz majg ignoranckie podejscie.

Nastepnie nalezy zaopatrzy¢ sie w Android SDK. Pobieramy je ze strony -
http://developer.android.com/. Osobiscie postuze sie instalatorem dla systemu Windows (troche
ponad 28 MB).



Java SDK i Java RE nalezy pobrac ze strony - http://www.java.com/.
Instalujemy!

Majac pobrane wyzej wymienione pliki mozemy przystgpi¢ do instalacji. W pierwszej kolejnosci
nalezy zainstalowac Java Software Development Kit oraz Java Runtime Environment. Proces instalacji
w tym wypadku nie jest niczym trudnym, wiec nie bede tego opisywac.

Po rozpakowaniu archiwum ze s$rodowiskiem Eclipse (na przyktad do katalogu na pulpicie)
wypadatoby je po raz pierwszy uruchomié. Uzytkownikowi natychmiast pojawi sie okno z wyborem
lokalizacji przestrzeni roboczej.

Select a workspace

Eclipse SDK stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

Workspace: (& P 2 Dzieniak\workspa v Browse...

Use this as the default and do not ask again

Cancel J

Mozna zostawic lokalizacje domyslng. Warto jednak jg zmieni¢ na taka, ktéra bedzie moéwita co$
wiecej o utworzonym katalogu. W moim przypadku bedzie to folder \Eclipse\Workspace\ w moich
dokumentach. Bedzie to domysiny katalog, w ktérym bede pracowaé. Zaznacze wiec, aby Eclipse przy
ponownym uruchomieniu nie pytat o katalog przestrzeni roboczej.
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Select a workspace
Eclipse SDK stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

Workspace: C:\Users\Tomasz Dzieniak\Documents\Eclipse\Workspace\

V| Use this as the default and do not ask again

OK ] \ Cancel ‘

Po tej operacji uruchomi sie gtdwny program. Zamknijmy go na chwile. Nalezy jeszcze zainstalowac
Android SDK.



W przypadku automatycznego instalatora wystarczy pozostawi¢ wszystkie opcje domysine (wtacznie
z uruchomieniem programu na zakonczenie instalacji). Menedzer, ktéry uruchomi sie na koniec
utatwia dostep do aktualnego APl Androida, pozwala na instalacje dodatkowych pakietéw (kontroler
USB, system wsparcia itd.). Okno menadzera przedstawia sie nastepujaco:

Packages Toaols

SDK Path: C:\Program Files (x86)\Android\android-sdk
Packages

Mame API Rev.  Status i

a4 [][] Tools
[[] X Android SDK Tools 16 9 lInstalled
[] % Android SDK Platform-tools 10 & Not installed

Android 4.0.3 (API15)

Android 4.0 (AP114)

Android 3.2 (AP113)

Android 3.1 (AP112)

Android 3.0 (AP111)

Android 2.3.3 (AP110)

Android 2.2 (AP18)

Android 2.1 (AP17)

Android 1.6 (AP14)

Android 1.5 (4P13)

Extras i

m,

J0oooooo@@a

Show: Updates/New [/]Installed  [7] Obsolete Select New or Updates Install packages...

Sort by: @ API level () Repository Deselect All Delete packages...

T ———— J
. . a
Fetching URL: http://android-sdk-addons.motodevupdate.com/addonsxml

Z racji na to, iz jedynym urzgdzeniem obstugujgcym Androida jakim dysponuje to smartfon HTC
Wildfire obstugujgcy Androida w wersji 2.2 proponuje zainstalowac ponizsze elementy:

Andreid SDK Manager | (O] | S
Packages Tools
SDK Path: C:\Program Files (x86)\Android\android-sdk
Packages
Name API Rev.  Status
> Tools
> Android 4.0.3 (API15)
> [T]1E] Android 4.0 (API114)
> [C]1=] Android 3.2 (API113)
> [C]1E] Android 3.1 (API12)
> [C]1E] Android 3.0 (API111)
» [C]1=] Android 233 (AP110)
> Android 2.2 (AP18)
> [C]1Z] Android 2.1 (APIT)
: [C]1E] Android 1.6 (AP14)
> [C]1E] Android 1.5 (AP13)
> Extras
Show: [¥|Updates/Mew [¥|Installed  [] Obsolete Select New or Updates [ Install 20 packeges... |
Sort by: @ APl level () Repository Deselect All [ Delete 1 package... ]
| o
Done loading packages.
L 4

Po wybraniu odpowiednich elementéw nalezy klikngé przycisk "Install ... packages...". Bedzie sie
rozni¢ w zaleznosci od wybranych pakietow. Proces instalacji jest stosunkowo czasochtonny.
Zwigzane jest to z koniecznoscig automatycznego pobierania pakietéw z serweréw dostawcy API.
Woystarczy juz tylko zaakceptowaé postanowienia licencyjne i poczeka¢ na koniec procesu instalacji.

Na zakonczenie instalacji powinniSmy uzyska¢ okno, w ktérym potwierdzona zostata instalacja
poszczegdlnych elementéw.



Packages Tools
SDK Path: C:\Program Files (xB6)\Android\android-sdk
Packages
MName APT Rev.  Status |«
4 | Tools
[ X Android SDK Tools 16 S9lInstalled L
[] ¢ Android SDK Platform-tools 10 Shinstalled 1
4 [] 1] Android 4.0.3 (AP115)
[71]%] Documentation for Android SDK 15 1 9 Installed
[] %' SDK Platferm 15 2 [Shinstalled
D& Samples for SDK 15 1 9 Installed
[] % ARM EABI w73 System Image 15 1 9 Installed
[7] ' Google APIs by Google Inc. 15 1 Shinstalled
] Sources for Android SDK 15 1 9 Installed
> [T]1E] Android 4.0 (AP114)
» [C]1E] Android 3.2 (API13)
> [C11E] Android 3.1 (API112)
> [M11Z] Android 3.0 (API111) S
Show: Updates/New [¥]Installed [ i0bsolete Select New or Updates Install packages...
Sort by: @ API level () Repository Deselect All Delete packages...
| ; u
Done loading packages.

Na zakonczenie pozostaje juz tylko zainstalowanie ADT i mozna zaczgé programowaé. W tym celu
nalezy zamkng¢ okno menedzera i ponownie uruchomié srodowisko Eclipse.

Klikamy nastepnie menu Help -> Install New Software... Pojawi sie okno, w ktérym mozna instalowaé
wtyczki z réznych zrédet (niekoniecznie tylko wspieranych przez producenta Eclipse).

= Install

e e

Available Software

Select a site or enter the location of a site. 3.1—
Work with:” [ add
Find more software by working with the "Available Software Sites” preferences,
type filter text
| Name Version

[[] @ Thereis no site selected.

Select All Deselect All

Details
Show only the latest versions of available software ["] Hide items that are already installed
[¥] Group items by category What is already installed?

["] Show only software applicable to target environment
[#] Contact all update sites during install to find required software

@ < Back Next > Ereh

W celu pobrania AWT nalezy dodac do Zzrodet oprogramowania adres do oprogramowania Androida -
https://dl-ssl.google.com/android/eclipse/.

Dotaczamy do instalacji Developer Tools jak na ilustracji:



= et =T

Available Software ’_
Check the items that you wish to install. :).L_
Work with:  Android - https://dl-ssl.geogle.com/andreid/eclipse/ -
Find more software by working with the "Available Software Sites” preferences,
type filter text
| Name Version

» [¥] 000 Developer Tools

Select All Deselect All 4 items selected

Details
Show only the latest versions of available software ["] Hide items that are already installed
[¥] Group items by category What is already installed?

[ Show enly software applicable to target environment

[#] Contact all update sites during install to find required software

@ < Back Next > Finish

...i postepujemy zgodnie z poleceniami instalatora. Ponownie nalezy poczekac na zakoriczenie tego
procesu. W trakcie informacji pojawi sie okno informujgce o instalacji oprogramowania nie
podpisanego cyfrowo przez dostawce S$rodowiska Eclipse. Oczywiscie nalezy potwierdzi¢ chec
kontynuowania instalacji i na zakonczenie wyrazi¢ zgode na ponowne uruchomienie programu.

Kiedy program uruchomi sie ponownie uzytkownikowi ukaze sie okno, za pomocg ktérego mozna
zainstalowac Android SDK, badz wskaza¢ lokalizacje juz zainstalowanego na komputerze. Jako, iz jest
juz ono dostepne na komputerze wskazujemy lokalizacje. Jezeli w czasie instalowania SDK nie zostata
zmieniona docelowa lokalizacja instalacji, nalezy podac¢ $ciezke podobng do tej przedstawionej na
ponizszej ilustracji.

-
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= Welcome to Android Development l ]| e S|

Welcome to Android Development r \
Configure SDK

To develop for Android, you need an Android 50K, and at least one version of the Android APIs to compile
against. You may also want additional versions of Android to test with.

() Install new SDK
[¥]Install the latest available version of Android APIs (supports all the latest features)
[]Install Android 2.1, a version which is supported by ~97% phones and tablets
(You can add additional platforms using the SDK Manager.)

Target Location:  C:\Program Files (x86)\Android\android-sdk

(@) Use existing SDKs

Existing Location:  C:\Program Files (x86)\Android\android-sdk

@ < Back Next > Eren

Pozostato juz tylko klikngé na przycisk Next i w nastepnym oknie potwierdzi¢ (badz nie) cheé
wysytania informacji o doswiadczeniu z oprogramowaniem do dostawcy API.



W tym momencie mozna klikngé menu File -> New -> Project... i zobaczy¢, ze w oknie dialogowym
pojawita sie mozliwo$é tworzenia aplikacji dedykowanych dla platformy Android.

- - - - -
= Mew Project [ (5] &J

Select a wizard —

Wizards:
type filter text

2% Java Project
¥ Java Praoject from Existing Ant Buildfile
£ Plug-in Project
. [ General
4 = Android
@ Android Project
& Android Sample Project
JEI Android Test Project
> = V5
2 = Java
+ == Plug-in Development
» [= BExamples

3 . -
@J < Back Mext = Einizh

Gotowe!

Z tak przygotowanym srodowiskiem uzytkownik gotowy jest do rozpoczecia przygody w Swiecie
mobilnej platformy Android!

Konfiguracja emulatora

Majgc gotowy projekt - w celu jego przetestowania - nalezy utworzy¢ jeszcze wirtualne urzadzenie,
na ktéorym bedziemy emulowaé utworzong aplikacje. W tym celu klikamy menu Run -> Run (badz
naciskamy Ctrl + F11). W tym momencie pojawi sie okno z informacjg, iz nie istniejg kompatybilne
urzadzenia, za pomocg ktérych mozna przetestowac aplikacje.

= Android AVD Error ) [




Potwierdzamy che¢ utworzenia takiego urzadzenia poprzez klikniecie przycisku Yes. W oknie, ktére

pojawi sie nastepnie klikamy przycisk New...

r N
Android Virtual Device Manager lﬂlﬂlﬁ

List of existing Android Virtual Devices located at C\Users\Tomasz Dzieniak'.android\avd
AYD Name Target Name Platform API Level CPU/AEI New...

Mo AVD available = = Edit...

Delete...
Repair...
Details...

Start...

Refresh

~ Avalid Android Virtual Device, A repairable Android Virtual Device,
X An Android Virtual Device that failed to load. Click 'Details' to see the error.

Wypetniamy nastepne okno na przyktad jak ponizej.

F B
2 Create new Android Virtual Device (AVD) ® % S5
MName: android_2_2
Target: Android 2.2 - API Level 8 VI

CPU/ABL | ARM (armeabi)

5D Card:
@) Size: | 2048 MiE
©) File: Browse...
Snapshot:
[ Enabled
Skir:
@) Built-in: Default (WVGABDD) hd
(") Resolution: x
Hardware:

Property Value

Abstracted LCD density 240
Max VM application hea... 24

Delete

Override the existing AVD with the same name

[ Create AVD J’ Cancel

...i klikamy Create AVD.



Co na zajeciach?

Na zajeciach zajmiemy sie podstawami programowania OpenGL ES dla Androida. M. in.:

utworzymy pierwszg aplikacje w OpenGL ES

— wyswietlimy na ekranie emulatora pierwszy prymityw (szescian)
— dodamy oswietlenie i teksture na prymitywie

— dodamy prostg animacje (iluzje obrotu prymitywu)

— dodamy przezroczystos¢ obiektu

Efekt koricowy

OpenGL

Autor instrukc ji Tomasz Dzieniak



